¿Quién se ha llevado mi sonido?

Estás trabajando tan a gusto con una buena música de fondo en YouTube (buena colección de música en un sitio de vídeos…), cuando de repente, entre canción y canción el sonido deja de funcionar. ¿Se habrá quedado el plugin de Flash colgado? Cierras todas las pestañas/ventanas/instancias del navegador, reintentas la conexión y nada. No se oye nada. Abres el player de mp3 y tampoco. Grabas un sonido con el asistente de GNOME y tampoco.


$ /etc/init.d/alsa-utils reset

Tampoco. ¿Reiniciar? ¿En Linux? No way.

Solución : (la dejo apuntada aquí porque me ha hecho falta ya varias veces y nunca me acuerdo del dichoso comando)

# lsof -w $( find /dev -group audio )

Esa línea nos da la lista de culpables que tienen el dispositivo de sonido ocupado. A continuación vamos matándolos por su PID ¡y listo! Volvemos a tener sonido y a trabajar (no sin antes documentar el paso en DiarioLinux, para el futuro 😉

Nota: el culpable era OpenOffice (cosa que nunca hubiera sospechado…)

8 comentarios sobre “¿Quién se ha llevado mi sonido?”

  1. Orale buen tip, lo pondré starred en mi Google Reader :D. A mi me pasa que escucho sonidos en mi Firefox y luego ya no puedo oir música en mi Amarok, y es por el pulseaudio :S, se me olvida desinstalarmelo y quedarme con alsa, y para solucionarlo solo mato a pulseaudio y listo.

    Chido tu blog, nos estamos leyendo.

  2. Pingback: Tot depen

Responder a mario Cancelar respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.