Ikasten.IO
Learning, Aprendiendo

¿Problemas con el audio en los vídeos Flash? 24 Julio, 2007

Lo primero: ¿qué tarjeta de audio estás usando?

sh-3.2$ aplay -l
**** Lista de PLAYBACK Dispositivos Hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: STAC92xx Analog [STAC92xx Analog]
Subdispositivos: 0/1
Subdispositivo #0: subdevice #0

Si lanzamos Firefox desde una terminal, veremos una serie de errores de acceso a dispositivos de /dev/snd.

Veamos:

sh-3.2$ ls -al /dev/snd
total 0
drwxr-xr-x 2 root root 120 2007-07-17 13:27 .
drwxr-xr-x 13 root root 14660 2007-07-17 13:27 ..
crw-rw—- 1 root audio 116, 0 2007-07-17 11:10 controlC0
crw-rw—- 1 root audio 116, 24 2007-07-17 11:10 pcmC0D0c
crw-rw—- 1 root audio 116, 16 2007-07-17 11:10 pcmC0D0p
crw-rw—- 1 root audio 116, 33 2007-07-17 11:10 timer

Ooops… permisos sólo para el root. Cambiémoslos:

sh-3.2$ cd /dev/snd
sh-3.2$ sudo chmod 0666 *
sh-3.2$ ls -al /dev/snd
total 0
drwxr-xr-x 2 root root 120 2007-07-17 13:27 .
drwxr-xr-x 13 root root 14660 2007-07-17 13:27 ..
crw-rw-rw- 1 root audio 116, 0 2007-07-17 11:10 controlC0
crw-rw-rw- 1 root audio 116, 24 2007-07-17 11:10 pcmC0D0c
crw-rw-rw- 1 root audio 116, 16 2007-07-17 11:10 pcmC0D0p
crw-rw-rw- 1 root audio 116, 33 2007-07-17 11:10 timer

Y el audio en los vídeos Flash vuelve a funcionar. ¡Bien!

Categorias diariolinux sonido
  • jci dice:

    Hola!

    te saldria mas corto meter al usuario en el grupo audio y listo. Eso es menos truculento que cambiar los permisos al dispositivo 😉

    Saludos!

    –j

  • admin dice:

    jci: ops! pues tienes razón, la solución que propones es más razonable. Gracias!

  • Cronopio dice:

    No solo como dice jci es mas truculento el proceso que dice en el post, es un practica que genera un error de seguridad.

    Cada dispositivo de la maquina tiene permisos para que no todo el mudo pueda optener acceso.

    Cuando cambias los permisos del dispositivo de esa forma estas dejando que como ejemplo yo me conecto a tu maquina desde la mía aquí en colombia y empiece a reproducir sonidos como loco.
    ¿Adivina a quien le sonaran?

    Por eso es mejor agregar a los usuarios que puedan usar la tarjeta de sonido al grupo audio.

    Saludos!!!

    PD: Este blog me parece muy interesante y lo visito con regularidad.

  • admin dice:

    Cronopio: estoy de acuerdo en que la solución correcta desde el punto de vista de la seguridad es meter al usuario en el grupo audio. Pero no estoy de acuerdo en lo que afirmas después, porque ¿cómo te conectas a mi máquina desde fuera (desde Colombia, en tu caso)? 😉

  • Etux dice:

    Emm bueno soy nuevo en linux y particularmente en kubuntu.. tengo ese mismo problema pero nose como ingresar el user al grupo audio.. porfavor me podrian agregar y ayudarme? bh_x2@hotmail.com

  • admin dice:

    Pues la forma más sencilla (yo uso Ubuntu y Fedora, ambos con GNOME) sería hacerlo desde el menú “Sistema/Administración/Usuarios y Grupos”

    En KUbuntu esa opción está en :
    K-menu->System Settings->Users and Groups

  • nimenos dice:

    Me salvaste el youtube, eres grande si señor… las peliculas no son lo mismo sin audio…GRACIAS!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *